When there is no other category, General is the way to go.
nabil
 
Posts: 1
Joined: Wed Feb 21, 2018 2:47 pm

Message sent twice after GPS fix timeout

by nabil Wed Nov 07, 2018 5:05 pm

Hi,

I have noticed a weird problem when sending a Sigfox message right after a GPS fix timeout: sometimes the message is sent twice with a few seconds interval.

Here's a log I managed to capture when the error occured:

--------------------------------------------------------------------
Time (UTC): 12:38:47
Date: 19/09/2018
Elapsed: 49/50 s
Usable sats = 1 - Ephemeris available: 1 - Ephemeris downloading: 0
--------------------------------------------------------------------
Time (UTC): 12:38:47
Date: 19/09/2018
Elapsed: 50/50 s
Usable sats = 1 - Ephemeris available: 1 - Ephemeris downloading: 1
--------------------------------------------------------------------
fix procedure timed out
Sending 11 bytes: C5, FF, FF, FF, FF, FF, FF, FF, FF, FF, 00
Time (UTC): 12:38:48 // Fix callback is reaccessed here!
Date: 19/09/2018
Elapsed: 58/50 s
Usable sats = 2 - Ephemeris available: 1 - Ephemeris downloading: 1
- --------------------------------------------------------------------
fix procedure timed out
Sending 11 bytes: C5, FF, FF, FF, FF, FF, FF, FF, FF, FF, 00


Here is a screenshot of the error on the Sigfox backend.

duplicate_message_backend.png
Duplicate message on Backend
duplicate_message_backend.png (9.17 KiB) Viewed 47 times


Does anyone have a clue on how to solve/debug this issue?

Regards,
Nabil
Return to General

Who is online

Users browsing this forum: No registered users and 1 guest