When there is no other category, General is the way to go.
Posts: 2
Joined: Mon May 02, 2016 9:22 am

Transmission Tests not working anymore (Error messages)

by nasscube Mon May 02, 2016 9:45 am


I'm using a TD1208EVB and I am trying to send a SigFox message but I keep receiving the Error message. The firmeware loaded is the last version : td1208_modem_SOFT1451.bin

The thing is that, when I received the board last week, I tried the "Cloud-on-Chip™ Transmission Test" and it worked. Now that my SigFox backend account has been created, I tried the "SIGFOX™ Transmission Test" but it is not working. Also, the "Cloud-on-Chip™ Transmission Test" is not working anymore and I keep getting the Error message for both of them.

For the AT&V command, I receive :
Code: Select all
Telecom Design TD1208
Hardware Version: ??
Software Version: SOFT1451
E1 V1 Q0 X1 S200:0 S300:24 S301:2 S302:14 S303:1 S304:20 S305:25 S350:0 S351:327
68 S352:1 S353:10 S400:000000 S401:FFFFFF S402:0 S403:869412500 S404:14 S405:32

I am pretty sure that last week, the Hardware Version was something like 0F and the S/N was 0000XXXX ending with the serial number of my board...

The only thing I did since then is programming the board with the blinking example project from Eclipse. I first loaded the binary file using the TDLoaderV1.06 and then, I managed to program it and launch a debug session with a J-Link debugger. I played with the J-Flash Lite tool (erasing the flash and programming the chip again).

Thank you for your help.
Posts: 31
Joined: Sun Jan 22, 2017 3:37 pm

Re: Transmission Tests not working anymore (Error messages)

by escalanterj Mon May 01, 2017 4:07 pm

no answer yet? I have the same problem...
User avatar
Posts: 168
Joined: Thu May 07, 2015 9:24 am

Re: Transmission Tests not working anymore (Error messages)

by mstempin Mon May 15, 2017 7:50 am

If the S/N is "FFFFFFFF", this means that the Sigfox ID has been erased from the separate User Information page in Flash memory. This is caused either by performing a Flash chip full erase or by flashing an inappropriate firmware (such as one of the EnergyMicro example for the STK3300 EVK board) into the CPU.

Unfortunately, there is no way to recover the ID and its associated key and the device will no longer be able to transmit on the Sigfox network.
Return to General

Who is online

Users browsing this forum: No registered users and 2 guests